Добре дошъл/дошла, Гост. Моля, въведи своето потребителско име или се регистрирай.

Влез с потребителско име, парола и продължителност на сесията

Новини:

Автор Тема: Проблем с вграждане на модул! - РЕШЕНО  (Прочетена 6843 пъти)

Неактивен b3ariben

  • За малко е тук
  • *
  • Публикации: 33
  • Репутация: 0
Здравейте!
Използвам версия на Джумла 2.5

Имам следния проблем при вграждането на модул.

Искам да поставя модул  в  HTML код и го вграждам както си трябва (поне така мисля)  ето;
{loadmodule името на модула}

Но модула не ми се показва , а просто на страница ми излиза точно кода за вграждане:
{loadmodule името на модула}

Преди тази версия на Джумла използвах 1.5 и нямах никакъв проблем с това, а сега изобщо не ми се показва модула.

Не знам какво се случва.

Да не би да трябва да включа още нещо освен Content - Load Modules

Нямам идея и за това се обръщам към Вас за вашата помощ.

Ето и една снимка след като сложа кода за вграждане  какво излиза, а там трябва да се появи един малък таймер:



Най-вероятно сте разбрали какво точно имам на предвид и Благодаря предварително на всички, които ще ми помогнат или поне ще се опитат да ми помогнат да разреша този проблем

Лек ден!
« Последна редакция: 14 Юли, 2014, 06:46:09 от b3ariben »

Неактивен Михаил Михов

  • Администратор
  • Мега Гуру
  • *
  • Публикации: 3912
  • @Mihail
  • Репутация: +80
    • MyWeb1
Re: Проблем с вграждане на модул!
« Отговор #1 -: 13 Юли, 2014, 11:04:41 »
0
Не публикувай 2 еднакви теми!

Като чета обяснението:
Цитат
Описание
Зарежда модулни позиции в статия, синтаксис: {loadposition user1}
myweb1.eu // Български платежни методи за HikaShop

Неактивен b3ariben

  • За малко е тук
  • *
  • Публикации: 33
  • Репутация: 0
Re: Проблем с вграждане на модул!
« Отговор #2 -: 13 Юли, 2014, 15:15:00 »
0
T.e.
С нищо не можеш да помогнеш, защото не ти е ясно какво трябва да се направи.
Това разбрах Аз или още по подробно да го обесня


Неактивен MOn dsoffn

  • Разбирач
  • *
  • Публикации: 1070
  • Репутация: +22
Re: Проблем с вграждане на модул!
« Отговор #3 -: 13 Юли, 2014, 15:28:03 »
0
Обясни го още мнооооооооооооооооооооооооооооооооооооооооооого по - добре, щото нищо не става ясно.

Когато на мен ми се налага да вградя модул някъде из кода, използвам: <jdoc:include type="modules" name="breadcrumbs" />
Не става ясно къде точно поставяш кода??

Тази снимка, показва модулна позиция ли или статия с картинка или какво?? За вграждане на модула ползваш ли някакви плъгини ??? Ако ползваш плъгини те съвместими ли са с модула, които ще вграждаш???

Дай линк към сайта където е проблема да го погледнем !!!

Обясни стъпка по стъпка какво правиш, за да разгадаем какво се опитваш да направиш и да ти обясним как да го направиш !!!

Имай предвид, че тези, които отговарят тука на 90% от случаите гадаят какво се опитва да направи питащия, понеже това което прави обикновено се прави по различен начин.

И не на последно място Мишо е един от малкото хора тука, от които можеш да научиш нещо, щото ще ти го кажи, а няма просто да подмине темата, щото го мързи да обяснява, както аз и други правим доста често  ;)

ПП -> При над 10-тото препрочитане на поста ти забелязах, че ти пишеш името на самия модул, които искаш да визуализираш, а това не e правилно, защото трябва да напишеш името на модулната позиция и да поставиш модула в тази позиция  ;)

Примерно поставяш модула mod_ostimer в позиция broqch и след това за да визуализираш модула  mod_ostimer трябва да ползваш {loadmodule broqch}

И в тоя ред на мисли, виж какво ти е написал мишо, просто той е ползвал модулна позиция user1, а не broqch  ;)

ПП2 -> Забелязах също, че мишо е ползвал {loadposition user1}, а не {loadmodule user1}. Предполагам че твоето е остаряло и е заменено от loadposition
« Последна редакция: 13 Юли, 2014, 15:40:07 от Donbaron.bg »

Неактивен b3ariben

  • За малко е тук
  • *
  • Публикации: 33
  • Репутация: 0
Re: Проблем с вграждане на модул!
« Отговор #4 -: 13 Юли, 2014, 16:22:56 »
0
Добре ето:

Значи в един

Модули: Модул HTML код

 Съм сложил три банера
Това е кода на един от банерите на който бях дал снимка малко по рано.
<li data-scroll-reveal="enter bottom and move 50px over 0.55s after 0.3s">
<div><img src="images/f2.bmp" border="0" alt="" /> <strong>- 30% REEBOK WOMEN SHOES<sub> {loadposition top2}</sub></strong></div>
</li>

И искам в него да сложа този таймер и от кода се вижда къде съм сложил модулната позиция на таймера, който искам да се появи.

Сега го пробвах и с модулна позиция

 {loadposition user1}

тоест
{loadposition top2}

 и пак не става. Не се появява.
Пробвах преди това и така
{loadmodule mod_ostimer}

Не действа.
А на Джумла 1.5 Слагам  {module mod_ostimer}

и работи
 :-\

Неактивен MOn dsoffn

  • Разбирач
  • *
  • Публикации: 1070
  • Репутация: +22
Re: Проблем с вграждане на модул!
« Отговор #5 -: 13 Юли, 2014, 16:30:05 »
0
А пробва ли с: <jdoc:include type="modules" name="името на модулната позиция" />
Може и да се получи.

Неактивен b3ariben

  • За малко е тук
  • *
  • Публикации: 33
  • Репутация: 0
Re: Проблем с вграждане на модул!
« Отговор #6 -: 13 Юли, 2014, 16:34:31 »
0
Не се получава в Модул HTML кода въобще не го приема този код

Ето сега създадох един нов

Модул HTML код и в него сложих само и единствено
{loadmodule mod_ostimer}

и на главната страница вместо таймера се поява пак
{loadmodule mod_ostimer}

Отделно пускам само таймера.. Той си работи и се появява, но когато искам да го сложа в банер както тези или както сега пробвах, само него в  HTML код чрез {loadmodule mod_ostimer} не се поява

Неактивен MOn dsoffn

  • Разбирач
  • *
  • Публикации: 1070
  • Репутация: +22
Re: Проблем с вграждане на модул!
« Отговор #7 -: 13 Юли, 2014, 16:42:54 »
0
Дай сайта ? Ако html модула които създаваш се намира в позиция user1, {loadposition трябва да е различно от user1}, примерно {loadposition user2} и таймера го слагаш в позиция user2

Предполагам това {loadposition user1} за да работи е необходим някакъв  плъгин. Имаш ли го инсталиран този плъгин ? Знаеш ли дали този плъгин работи по този начин или работи само с определени компоненти ? Прочети инструкциите на плъгина. Кажи кои е плъгина, ако има такъв ? Настроен ли е правилно плъгина? Брояча публикуван ли е ?


Неактивен b3ariben

  • За малко е тук
  • *
  • Публикации: 33
  • Репутация: 0
Re: Проблем с вграждане на модул!
« Отговор #8 -: 13 Юли, 2014, 16:58:07 »
0
Ето го сайта сега го оправям. Тоест е работен сайт.


 И позициите им са различни не са едни и същи, плъгина си е Content - Load Modules
newbielink:http://fresh.zaribenshop.com/ [nonactive]

Неактивен Бого

  • Администратор
  • Гуру
  • *
  • Публикации: 2268
  • Репутация: +28
Re: Проблем с вграждане на модул!
« Отговор #9 -: 13 Юли, 2014, 17:36:37 »
0
T.e.
С нищо не можеш да помогнеш, защото не ти е ясно какво трябва да се направи.
Това разбрах Аз или още по подробно да го обесня

Колега, беше ти обяснено, но ти липсват  знания и затова не го разбра.
Ако не можеш да се справиш дай ми права и да приключим с този въпрос.

Не давай квалификации за хора,  на който не им знаеш възможностите.

Второ, ако пуснеш още веднъж две еднакви теми ще имаш забрана за месец за пускане на нова тема!
« Последна редакция: 13 Юли, 2014, 17:39:19 от Бого »
Joomla, произлиза от думата Jumla (на суахили), която означава `всички заедно`, като потвърждение на open source инициативата!

Неактивен b3ariben

  • За малко е тук
  • *
  • Публикации: 33
  • Репутация: 0
Re: Проблем с вграждане на модул!
« Отговор #10 -: 13 Юли, 2014, 17:43:00 »
0
И какви по точно квалификации съм дал.
 и Как ми беше обеснено.
Беше ми обеснено нещо, което правех няколко пъти до сега и нищо различно не ми беше обеснено.

Сега някой ако ги мързи да пишат въобще не намирам смисъл да "помагат" с едно дума.

Лек вечер

Неактивен Бого

  • Администратор
  • Гуру
  • *
  • Публикации: 2268
  • Репутация: +28
Re: Проблем с вграждане на модул!
« Отговор #11 -: 13 Юли, 2014, 17:52:09 »
0
Тук на никой не е длъжен с нищо, всичко е на доброволни начела.

Бъркаш със сигурност някъде, затова ако искаш дай ми права.
Joomla, произлиза от думата Jumla (на суахили), която означава `всички заедно`, като потвърждение на open source инициативата!

Неактивен MOn dsoffn

  • Разбирач
  • *
  • Публикации: 1070
  • Репутация: +22
Re: Проблем с вграждане на модул!
« Отговор #12 -: 13 Юли, 2014, 18:40:07 »
0
Трябва да дадеш права поне да се идентифицираме да видим какво не става, но щом вече втори човек ти казва че с {loadposition user2} ще стане, значи някъде бъркаш.

Трябва позицията която вмъкваш да е различна от тази в която я вмъкваш. Трябва модула да е публикуван в позицията която вмъкваш. Трябва на модула да му е позволено да се показва в страницата в която ще се показва (сложи го да се показва на всички страници).

Ако се използва някакъв плъгин, то той трябва да бъде инсталиран, настроен и публикуван. Преди да бъде използван, трябва да си запознат с неговите функции и възможности.

Неактивен b3ariben

  • За малко е тук
  • *
  • Публикации: 33
  • Репутация: 0
Re: Проблем с вграждане на модул! - РЕШЕНО
« Отговор #13 -: 14 Юли, 2014, 06:53:00 »
0
Здравейте на всички!

Проблема го реших и то беше в това, че в Модул HTML код не бях включил Подготовка на съдържанието..

След като го включих модула се показа и работи и с {loadposition моята позиция} и  {loadmodule името на модула}

Благодаря на всички, които се опитаха да помогнат и отделиха от времето си. Ако някой съм засегнал съжалявам, както и за това, че пуснах две едни и същи теми!

Имам още един въпрос и проблем, но тази седмица нямам време да се занимавам  със сайта, за това като ми остане време ще го споделя с Вас за да го разрешим отново!

Успешна седмица!

 :)

Неактивен Бого

  • Администратор
  • Гуру
  • *
  • Публикации: 2268
  • Репутация: +28
Re: Проблем с вграждане на модул! - РЕШЕНО
« Отговор #14 -: 14 Юли, 2014, 22:47:11 »
0
Радвам се, че си разрешил проблема и си разбрал, че не трябва да се пускат две еднакви теми!  :)
Joomla, произлиза от думата Jumla (на суахили), която означава `всички заедно`, като потвърждение на open source инициативата!