Добре дошъл/дошла, Гост. Моля, въведи своето потребителско име или се регистрирай.
Изгубил си активационния е-мейл?

Влез с потребителско име, парола и продължителност на сесията

Новини:

Автор Тема: Не мога да сменя версията на PHP...  (Прочетена 3059 пъти)

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #15 -: 26 Септември, 2018, 10:42:18 »
0
Да, много благодаря за идеята.   (relax) 8)

Малко рисково е за тоя, който няма опит в решаването на такива "кръстословици", но не е китайско писмо  (beer) (beer)

Обаче аз първо трябва да реша по-малкия проблем, защото и той може да ми попречи. Така мисля.
 
За 7.1 трябва да е:
[Thu Sep 20 20:45:25 2018] [error] [client ...] File does not exist: /home/.../public_html/favicon.ico, referer: newbielink:https://em-stanev.org/ [nonactive]
[Thu Sep 20 20:45:25 2018] [error] [client ...] File does not exist: /home/.../public_html/favicon.ico

Не трябва ли изпървом да подкарам версия 7.1 ?
favicon.ico го копирах в главна директория, но все тая.

Подкарам ли 7.1 скачам за 7.2 8)

Joomla! България

Re: Не мога да сменя версията на PHP...
« Отговор #15 -: 26 Септември, 2018, 10:42:18 »

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #16 -: 08 Октомври, 2018, 10:35:42 »
0
Чат пат се сещам за проблема по смяната на PHP версията.
Днес открих проблем с това на картинката:
« Последна редакция: 08 Октомври, 2018, 10:38:17 от emstane »

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #17 -: 08 Октомври, 2018, 10:37:45 »
0
Този компонент мисля е важен за сайта (или не?)
Може ли да го затрия и да инсталирам някакъв негов аналог?

Ще мине ли без особени проблеми тая трампа или не.
Най-малкото тая джаджа не може да се ъпдейтва....

На отзовалите се благодаря предварително  8) (relax) (coffee) jd

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #18 -: 08 Октомври, 2018, 11:02:35 »
0
Картинката се вижда само при логване....

Неактивен Михаил Михов

  • Администратор
  • Мега Гуру
  • *
  • Публикации: 3777
  • @Mihail
  • Репутация: +69
    • MyWeb1
Re: Не мога да сменя версията на PHP...
« Отговор #19 -: 09 Октомври, 2018, 10:18:00 »
0
Спирай го + компонента, модула и плъгина.
myweb1.eu // Български платежни методи за HikaShop

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #20 -: 09 Октомври, 2018, 11:11:54 »
0
Спрях, но не решава проблема.

Но изнамерих това:

"Временната директория за PHP не е указана


Временната директория за PHP е тази, която PHP използва да запазва качени файлове преди Joomla! да ги достъпи. Ако имате проблеми с инсталационните файлове (не може да бъдат намерени или качени на сървъра), настройте пътя във файла php.ini, като това в повечето случаи решава проблема. "

Това има ли отношение към ъпгрейда на PHP версията и ако да, как се решава по принцип проблема?
 (relax) (coffee)

Неактивен Михаил Михов

  • Администратор
  • Мега Гуру
  • *
  • Публикации: 3777
  • @Mihail
  • Репутация: +69
    • MyWeb1
Re: Не мога да сменя версията на PHP...
« Отговор #21 -: 09 Октомври, 2018, 15:52:18 »
0
He
myweb1.eu // Български платежни методи за HikaShop

Неактивен Уеб дизайн Seo

  • Мега Гуру
  • *
  • Публикации: 2713
  • 3D Web Design - разработка на добавки за Joomla
  • Репутация: +38
    • 3DWebDesign
Re: Не мога да сменя версията на PHP...
« Отговор #22 -: 09 Октомври, 2018, 16:13:31 »
0
Мишо, любопитен съм да видя дали накрая ще го научиш как да го оправи или не. Ако успееш, явно те влече - направо ти пращам 40-50 човека на обучение :)
Практически Joomla курс и обучения. Записване на 0898615736 или тук: Джумла курсове и обучение | Joomla extensions от 3D Web Design

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #23 -: 09 Октомври, 2018, 18:40:53 »
0
Ако кажеш, че искаш само акаунта на Joomla, без Cpanel-a и до 20-40 лв. ще вдигнеш на PHP 7.2, но първо ще оправиш да бачка на 7.1 - че така е препоръчително и разумно, пращам акаунта веднага на мейл.

За Cpanel-a малко ще се замисля, т.е. ще го отложа за по-спокойно за мен време, че задачи бол.  (beer) (beer)

Неактивен MOn dsoffn

  • Разбирач
  • *
  • Публикации: 1065
  • Репутация: +22
Re: Не мога да сменя версията на PHP...
« Отговор #24 -: 10 Октомври, 2018, 11:31:18 »
0
Мишо, любопитен съм да видя дали накрая ще го научиш как да го оправи или не. Ако успееш, явно те влече - направо ти пращам 40-50 човека на обучение :)

Така като гледам на къде вървят нещата няма стане, но определено Мишо има дарба!

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Бъг след ъпдейт на Джумла 3.9
« Отговор #25 -: 30 Октомври, 2018, 17:17:24 »
0
Бъг след ъпдейт на Джумла 3.9 - от 3.8. Бял екран.

Сайта работеше на PHP 7.0 и не можеше да се дигне до 7.2.
Дали това е причината или че шаблона е стар? Или нещо друго?
Някой има ли идея?

Каквото и да е, като имам повече време ще се захвана за проблемите (дано тия дни).

Благодаря предварително  (relax) (coffee) 8)

Неактивен Nikitov

  • Гуру
  • *
  • Публикации: 1622
  • Ха, НАЗДРАВЕ!!!
  • Репутация: +25
Re: Не мога да сменя версията на PHP...
« Отговор #26 -: 31 Октомври, 2018, 08:46:43 »
0
Вчера вечерта направих ъпдейт на няколко сайта и нямам подобни проблеми.
Ако те съмнява шаблона, просто направи експеримент като превключиш някой друг шаблон да е по подразбиране.
-------------------------
Ха, НАЗДРАВЕ!!! (beer)
"Прави това, което не си правил, за да се научиш" - К. Керин

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #27 -: 26 Декември, 2018, 17:21:55 »
0
Тогава изтегли и инсталирай akeebabackup:
newbielink:https://www.akeebabackup.com/products/akeeba-backup.html [nonactive]
Виж в настройките кои файлове и директории са и махни всичко, което не е на Джумла. Това го направи и за таблиците в базата данни. // wp се игнорира за запис в бекъп-а !

1. След това си направи си бекъп от там и го свали на компа. //ако разчиташ на хостинга ще ти върне всичко с 'боклука'
//търсиш wp
2. Влез през FileZilla и пусни търсенето в папка по папка в основната директория и public_html.
3. Записваш си данните от резултата и триеш всички папки и файлове с wp.
4. Проверяваш базата данни за наличие на таблици с wp и ако има такива запиши резултата и ги изтрий.
5. През интервал от минута до час провери дали това, което си изтрил няма да цъфне отново...
Изпълнено, но проблема си стои. Не знам дали шаблона изобщо ще работи на PHP 7.2, но до 7.1 версия със сигутност ще тръгне. И админа на хостинга също така смята.
Чистих остатъци тук таме, но без резултат. При смяна от 7.0 на 7.1 дава:

File does not exist: /home/.../public_html/favicon.ico

а фавикон-а го има в главна директория и при шаблона... Ако някой има друга идея, да каже  (coffee) (relax)
Или оферта за помощ към 7.1 също  jd
« Последна редакция: 26 Декември, 2018, 17:24:37 от emstane »

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #28 -: 27 Декември, 2018, 18:57:20 »
0
Навремето като се учех или, от що ли, не мога да деинсталирам старите шаблони. Някъде из нет-та препоръчват да се деинсталират.
Някой има ли идея как да го направя ръчно, че автоматиката не действа. Само папките да изтрия не е добра идея :)
« Последна редакция: 27 Декември, 2018, 18:59:41 от emstane »

Неактивен emstane

  • Загряващ
  • *
  • Публикации: 158
  • Репутация: 0
Re: Не мога да сменя версията на PHP...
« Отговор #29 -: 31 Декември, 2018, 15:36:19 »
0
Яйде за последно във старата 2018 - един класически въпрос.

Ако инсталирам текущата версия на Joomla, както се инсталира например обикновено всеки модул:

- Дали има шанс да се оправи някой-друг стар бъг.
- Дали сайтът ще продължи да си работи, без да се забележат някакви промени?

Някой правил ли го е този номер?

Наздраве  (beer) (beer) и за много години  (relax) 8)
For a many happy returns  :D

Joomla! България

Re: Не мога да сменя версията на PHP...
« Отговор #29 -: 31 Декември, 2018, 15:36:19 »